MyPortal
Incident Report for BluIP, Inc.
Resolved
This incident has been resolved.
Posted Aug 17, 2017 - 15:38 PDT
Investigating
We are experiencing intermittent issues with the MyPortal login page (myportal.masteraccess.com). If you cannot reach the portal page, please refresh your browser and attempt to re-connect. We will keep you updated as more information is gathered regarding this. Thank you for your patience.
Posted Aug 17, 2017 - 10:15 PDT