"portal.bluip.io" Currently Under Maintenance
Incident Report for BluIP, Inc.
Resolved
Services restored.
Posted Nov 22, 2022 - 10:52 PST
Identified
"https://portal.bluip.io" is currently in maintenance until further notice. If you have any questions or concerns, please email BluIP support at support@bluip.com.
Posted Sep 04, 2022 - 21:14 PDT
This incident affected: bluip.io.