Our engineering team continues to work on this issue alongside our vendor. As part of the resolution, we are removing the affected service pack identified as the source of the reported behavior. Removing this component is expected to address the underlying bug and restore normal operation across the affected services.
Once the removal is complete, we will continue to monitor closely to confirm recovery and ensure the issue does not recur. We will provide a further update as this work progresses.
Posted Jun 11, 2026 - 07:34 PDT
Update
Status: Identified
Update Our engineering team has traced these issues to what seems to be a newly discovered bug in an underlying user service. The bug appears to affect how the service handles call state and delivery, which accounts for the range of symptoms reported. We are working with our vendor to resolve the issue and are actively working to implement a fix.
This root cause seems to account for the reported behavior across all affected services. We will provide an update as the fix progresses.
Posted Jun 10, 2026 - 17:02 PDT
Identified
Status: Identified
Update Our engineering team has traced these issues to what seems to be a newly discovered bug in an underlying user service. The bug appears to affect how the service handles call state and delivery, which accounts for the range of symptoms reported. We are working with our vendor to resolve the issue and are actively working to implement a fix.
This root cause seems to account for the reported behavior across all affected services. We will provide an update as the fix progresses.
Posted Jun 10, 2026 - 17:02 PDT
Investigating
Status: Investigating
Impact: Intermittent — affecting call delivery across call centers
Summary
We are investigating reports of multiple calls being delivered from the call center queue to users who are already engaged on an active call. Under normal operation, a user on a call should not receive additional calls from the queue until they have completed their current call and returned to an available state. In the affected scenario, users may receive one or more additional calls from the queue while still on a call, resulting in disrupted call handling.
This behavior appears to be intermittent and may not affect all call centers. Our engineering team is actively investigating to determine the root cause.
Workaround
None at this time. We will provide an update as more information becomes available. Thank you for your patience in this matter.
Posted Jun 10, 2026 - 12:53 PDT
This incident affects: Call Center (Call Control).